文言文编程语言来了,可是好像比英文更难写了!

oschina
 oschina
发布于 2019年12月19日
收藏 35

近日有开发者开源了一门新的编程语言,吸引了大量开发者的目光,短短几天获得了 3k+ star。

该语言名为“文言(wenyan-lang)”,这是一门采用文言文输入的编程语言,该语言不包括英文字符,仅包含繁体中文字符,并保留繁体引号「」。

先看看 Helloworld 怎么写:

吾有一數。曰三。名之曰「甲」。
為是「甲」遍。
	吾有一言。曰「「問天地好在。」」。書之。
云云。

这段代码等效于以下 JavaScript 代码:

var n = 3;
for (var i = 0; i < n; i++) {
	console.log("問天地好在。");
}

输出:

問天地好在。
問天地好在。
問天地好在。

同时,标点和换行符是完全可选的,与古汉语一致,所以上面的代码等效于:

吾有一數曰三名之曰「甲」為是「甲」遍吾有一言曰「「問天地好在」」書之云云

Helloworld 看上去虽然简单,但是其实作为一门编程语言,这里的语法都有严格的定义:

变量

wenyan JavaScript
吾有一數。曰三。名之曰「甲」。 var a = 3;
有數五十。名之曰「大衍」。 var dayan = 50;
昔之「甲」者。今「大衍」是也。 a = dayan;
吾有一言。曰「「噫吁戲」」。名之曰「乙」。 var b = "alas!";
吾有一爻。曰陰。名之曰「丙」。 var c = false;
吾有一列。名之曰「丁」。 var d = [];
吾有三數。曰一。曰三。曰五。名之曰「甲」曰「乙」曰「丙」。 var a=1,b=3,c=5;

控制

wenyan JavaScript
若三大於二者。乃得「「想當然耳」」也。 if (3>2){ return "of course"; }
若三不大於五者。乃得「「想當然耳」」。若非。乃得「「怪哉」」也。 if(3<=5){return "of course"}else{return "no way"}
為是百遍。⋯⋯ 云云。 for (var i = 0; i < 100; i++){ ... }
恆為是。⋯⋯ 云云。 while (true) { ... }
凡「天地」中之「人」。⋯⋯ 云云。 for (var human of world){ ... }
乃止。 break;

运算

wenyan JavaScript
加一以二。 1+2
加一於二。 2+1
加一以二。乘其以三。 (1+2)*3
除十以三。所餘幾何。 10%3
減七百五十六以四百三十三。名之曰「甲」。 var a = 756-433;
夫「甲」「乙」中有陽乎。 a || b
夫「甲」「乙」中無陰乎。 a && b

容器

数组从 1 开始索引。

wenyan JavaScript
吾有一列。名之曰「甲」。充「甲」以四。以二。 var a = []; a.push(4, 2);
銜「甲」以「乙」。以「丙」 a.concat(b).concat(c);
夫「甲」之一。 a[0]
夫「甲」之其餘。 a.slice(1);
夫「玫瑰」之「「名」」。 rose["name"]
夫「寶劍」之長。 sword.length;

函数

wenyan JavaScript
吾有一術。名之曰「吸星大法」。是術曰。⋯⋯是謂「吸星大法」之術也。 function f(){...}
吾有一術。名之曰「六脈神劍」。欲行是術。必先得六數。曰「甲」。曰「乙」。曰「丙」。曰「丁」。曰「戊」。曰「己」乃行是術曰。⋯⋯是謂「六脈神劍」之術也。 function f(a,b,c,d,e,f){...}
吾有一術。名之曰「翻倍」。欲行是術。必先得一數。曰「甲」。乃行是術曰。乘「甲」以二。名之曰「乙」。乃得「乙」。是謂「翻倍」之術也。 function double(a){var b = a * 2; return b;}

但是作者表示上下文无关的语法描述还在构建中。

文言语言采用自然语言处理共享了古典汉语语法,将语言编译为 JavaScript 或 Python,并且图灵完备。同时它不仅提供了一个配套在线 IDE,还提供了大量算法与数据结构示例,包括快排、汉诺塔问题与斐波那契数列表示等。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:文言文编程语言来了,可是好像比英文更难写了!
加载中

精彩评论

icoffin
icoffin
如果计算机和编程语言是中国首先发明的,那真的是老外的噩梦
百科上神
百科上神
嗯,中国终于是做研究的闲人了。这是文艺爆发的初潮。
Nainse9
Nainse9
有这古文造诣你写啥程序,做个国学大师多好
画面
画面
评论里别那么严肃嘛,作者也是写着玩儿。。。
量子超算
这是脑残呀 把简单的 故意搞得 复杂
应该这样写
若(诸葛亮.活着)
{
屏幕.打印("诸葛亮还活着");
}然{
屏幕.打印("诸葛亮已经死了");
}

最新评论(106

BigBear
BigBear
有意义么?
布衣君
布衣君
真闲啊。。
x
x13989
那只是造轮子,而且是把轮子造在热门或者有需求的应用领域。但是这个既不是造轮子,又没有应用价值。
x
x13989
而且难以和其他编程语言融会贯通。举个例子,学了C++一会,C#和Python看几天就懂了。易语言转成C++也就是翻译个关键字的事。但是wyw这种形式的语言就是个孤岛,没法融会贯通。
x
x13989
虽然我不用易语言,但这还真的不如易语言,太晦涩了,特别是给学生,中考模考文言文得分率不高。
SEATECK
SEATECK
不太赞同,如果都是从实用性出发,那创新至少会少一半,也就不一定会有Py,会有Java了,不管怎么样,大佬能有这个文言体写代码的想法和创新,就够屌了
s
szcgy
如果你觉得这个没有用,那是你没有尝试过帮文科生入门编程,一下就起兴趣了:joy:
初级搬砖工
初级搬砖工
看起来不错,可是写的字太多了,效率太低
SPFA之死
SPFA之死
我问一下:这玩意速度有没有C快?代码有没有Py简洁?通用性有没有Java好?综合素质比得过谁?在国际上使用这个语言容易理解吗?如果以上回答都是否定,那这玩意和花瓶有什么区别?
Yu7
Yu7
你自己做不出来就说人家闲的。我看你是酸的。你也别告诉我你会做,不屑去做,做出来再说,不然就是酸。
返回顶部
顶部