Redis 6.0.8 发布,建议尽快升级

xplanet
 xplanet
发布于 2020年09月11日
收藏 5

Redis 6.0.8 发布了。之前 6.0.7 被称作最后一个 6.x 版本,但 Redis 团队表示 6.0.8 版本升级迫切性等级为高:任何将 Redis 6.0.7 与 Sentinel 或 CONFIG REWRITE 命令配合使用的人都会受到影响,应尽快升级。

Bug 修复

  • 通过 CONFIG SET 设置 oom-score-adj-value 或从配置文件加载 oom-score-adj-value 后,CONFIG REWRITE 将生成损坏的配置文件,这会导致 Redis 无法启动
  • 修复 MacOS 上的 redis-cli --pipe 问题
  • 修复 HKEYS/HVALS 在不存在的密钥上的 RESP3 响应
  • 各种小的 bug 修复

新特性

  • 设为 madvise 时,删除 THP 警告
  • 允许 EXEC 在集群中的只读副本上使用读取命令
  • 将主/副本选项添加到 redis-cli --cluster 调用命令

详情见发布公告

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Redis 6.0.8 发布,建议尽快升级
加载中

精彩评论

北极心
北极心
5.0.7路过
Leon_wy
Leon_wy
5.0 走起
自由PHP
自由PHP
嗯嗯,主机面板里面有升级的我就升级
Error-Erro-Err
Error-Erro-Err
5.0 +1
SpringBoot中文社区
SpringBoot中文社区
spring-data-redis 现在支持6了么?

最新评论(10

住在南山
住在南山
很强大
战场原礼亚
战场原礼亚
2.8飘过。。。
幸运果
幸运果
昨天刚下载的6.0.7。。。
W
WindSpeed
5都没用上还在4呢
z
zb43481584
5.0是稳定版本,6.0作者都说了不建议立马在生产环境部署,可能需要多等几个版本稳定了吧,现在阿里云上的Redis也最高只到5.0
北极心
北极心
5.0.7路过
Leon_wy
Leon_wy
5.0 走起
自由PHP
自由PHP
嗯嗯,主机面板里面有升级的我就升级
Error-Erro-Err
Error-Erro-Err
5.0 +1
SpringBoot中文社区
SpringBoot中文社区
spring-data-redis 现在支持6了么?
返回顶部
顶部