Flutter 开始支持 Windows

xplanet
 xplanet
发布于 2020年09月25日
收藏 8

本周,Flutter 团队发布了 Flutter Windows 的首个 Alpha 版本,正式开启 Flutter 对 Windows 的支持。

作为一款跨平台移动应用构建工具,Flutter 最初只支持 Android 和 iOS,去年五月开始又逐渐将支持扩展到桌面级别。今年七月初,谷歌还和 Canonical 合作,联合推出了 Linux 版 Flutter

谷歌产品经理 Chris Sells 称,根据他们的统计数据,Flutter 开发者中有超过半数在使用 Windows,因此对 Windows 的支持是自然而然的。

Flutter 每添加到一个新的平台,都会带来一些新服务,以扩展核心框架。起初提供 Material Design 风格的,基于触摸屏的界面,以移动设备为中心。而现在增加对桌面端的支持后,也进行了及时适配,包括对键盘、鼠标和控制器的支持,以及对较大屏幕尺寸的支持。

随着 Alpha 版本的发布,Flutter 社区已经开发了一些适用于 Windows 的插件,这些插件也同样能够支持其他 Flutter 平台。

除了支持经典的 Win32 API 外,Flutter 团队还在试验基于 UWP 的 Flutter shell 版本,这使得 Flutter 可以用于 Xbox 以及 Windows 10 模拟器等在内的更多 Windows 设备。

该团队接下来的主要工作包括无障碍功能、全球化、本地化,对键盘和文本处理的增强,以及对命令行参数的支持等。目前,Flutter Windows 支持 Windows 7 以上版本,预计在数月内会推出稳定版。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Flutter 开始支持 Windows
加载中

精彩评论

壹城
壹城
微软:Windows支持Linux了,.net 可以在Linux和Mac上开发了。
苹果:Swift 增加对 Windows 和其他 Linux 发行版的支持。
谷歌:大家后台可以用Go,前台可以用Flutter。
iman123
iman123
去年就可以在windows上运行了(直到目前,此特性还只能在master channel中),但直到现在状态还是正在开发中(WIP),api相比MacOS、Linux还不成熟,我之前也写过一些简单的程序(使用到的package是纯dart的,就可以兼容Windows)就使用了flutter,现在越来越多的官方维护的package已经兼容windows了,例如path_provider(https://pub.dev/packages/path_provider),shared_preferences(https://pub.dev/packages/shared_preferences)已经兼容了,后面的video、audio、...等也兼容了那就太方便了
门后无窗
门后无窗
我一眼就看到了xbox手柄
DanoR
DanoR
互 相 入 侵

最新评论(19

iman123
iman123
上面说错了,现在windows与macos、linux地位一样了,都可以在dev channel中运行了
门后无窗
门后无窗
我一眼就看到了xbox手柄
宿命
宿命
想多了吧,即使ios,android,也都是opengl啊
吴题
吴题
去年编译了windows版本的基于opengl生成起来好大,就没玩了,这种应该原生态的吧,应该会几mb大小吧。谁有没有编译过说下大小。
喵星人123
喵星人123
Qt怎么办
魂祭心
魂祭心
flutter支持linux么
DanoR
DanoR
互 相 入 侵
ifzm
ifzm
能不能把 map 模块做好 /狗头
壹城
壹城
微软:Windows支持Linux了,.net 可以在Linux和Mac上开发了。
苹果:Swift 增加对 Windows 和其他 Linux 发行版的支持。
谷歌:大家后台可以用Go,前台可以用Flutter。
iman123
iman123
去年就可以在windows上运行了(直到目前,此特性还只能在master channel中),但直到现在状态还是正在开发中(WIP),api相比MacOS、Linux还不成熟,我之前也写过一些简单的程序(使用到的package是纯dart的,就可以兼容Windows)就使用了flutter,现在越来越多的官方维护的package已经兼容windows了,例如path_provider(https://pub.dev/packages/path_provider),shared_preferences(https://pub.dev/packages/shared_preferences)已经兼容了,后面的video、audio、...等也兼容了那就太方便了
返回顶部
顶部