Linux 5.10.5 发布,5.10 内核系列的所有用户都必须升级

御坂弟弟
 御坂弟弟
发布于 2021年01月08日
收藏 0

1 月 6 日,Linux 基金会 宣布了 Linux 5.10.5 的发布,并且所有 5.10 内核系列的所有用户都必须升级。

此次更新采取了去年 10 月份讨论的一个补丁:禁用 Linux 帧缓冲控制台(FBCON)中的加速滚动( accelerated scrolling )。因为在 FBCON 的代码中频繁发现 bug,尤其是关于代码滚动。并且,目前仅有 3 个驱动程序使用它。

Linux 5.11 已经包含了放弃加速滚动的补丁,而此次发布的Linux 5.10.5版本将这一更改向下移植到当前的 LTS 版本中。

此外,此次更新还包括:

  • 修复运行时电源管理代码中的竞争
  • 修复 send_sig {io,urg}()中潜在的死锁
  • 修复 sanity_check_raw_super()中的越界问题
  • 修复 in sun6i_rtc_clk_init 中的内存泄漏
  • 修复 in ethnl_set_channels() 中的错误路径
  • ......

更多详细内容:https://lore.kernel.org/lkml/160995253074219@kroah.com/

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Linux 5.10.5 发布,5.10 内核系列的所有用户都必须升级
加载中

精彩评论

eechen
eechen
无需编译,1分钟安装Ubuntu官方构建的最新版Linux内核
https://my.oschina.net/eechen/blog/202438
http://kernel.ubuntu.com/~kernel-ppa/mainline/

最新评论(17

欧阳春晖
欧阳春晖
回复 @cevin : 只要不删除原的依赖so,应该问题不大,linux可以共存,再说很多动态库是向上兼容API。如果你真的遇到这种问题,您哭禁用该服务
cevin
cevin
回复 @欧阳春晖 : 关键是个openssl的安全更新自动安装了。然后依赖他的包比如php和一些加密扩展啥的就GG了……半天还不知道为啥然后就切回了debian.
欧阳春晖
欧阳春晖
我查了下,我的系统好像也有这个玩意,不过我并不反对紧急安全补丁相关的自动更新(不要自动更新软件包就行)

解除命令:systemctl stop unattended-upgrades
systemctl disable unattended-upgeades
欧阳春晖
欧阳春晖
kubuntu似乎暂时没有发现这个问题,都可以禁用,apt或者systemctl 的组合,我也是用同样的方法禁用snapd的,甚至有些东西有自己的ctl可以禁用,比如kde的索引
欧阳春晖
欧阳春晖
好吧 那你可以禁用这个更新器,都可以禁用的
cevin
cevin
标识安装了新版ubuntu后自动安装了一个叫unattended-upgrades的程序。线上服务器从来没有执行过apt的任何命令。然后就突然有一天安全补丁自动安装了。发邮件咨询官方maillist,被告知是自动更新器。
欧阳春晖
欧阳春晖
没有,只是有一个提示,所谓的更新器都是apt的后端
cevin
cevin
新版ubuntu有了自动安全更新了
欧阳春晖
欧阳春晖
你自己不更新就不会
eechen
eechen
无需编译,1分钟安装Ubuntu官方构建的最新版Linux内核
https://my.oschina.net/eechen/blog/202438
http://kernel.ubuntu.com/~kernel-ppa/mainline/
返回顶部
顶部